You are currently viewing Как создать удобный чек-лист (контрольный список) в Excel, чтобы ничего не забыть

Как создать удобный чек-лист (контрольный список) в Excel, чтобы ничего не забыть

Excel – довольно удобный инструмент с обширным функционалом. Множество приложений предлагают возможность создавать различные списки, но зачем пользоваться другими программами, если есть Excel?

Как создать удобный чек-лист (контрольный список) в Excel

Ниже мы покажем, как создать таблицу с флажками, которые вы можете удалять по мере выполнения задач. Excel даже отобразит, когда вы снимете все флажки. Создать таблицу довольно просто. Для этого нужно открыть вкладку «Разработчик», внести список задач, добавить флажки и расширенное форматирование. А теперь по порядку.

1. Открыть вкладку «Разработчик»

По умолчанию вкладка «Разработчик» не отображается. Ее можно добавить в ленту следующим образом: откройте «Файл» → «Параметры» → «Настроить ленту». В списке «Основные вкладки» установите флажок «Разработчик», а затем нажмите «Готово».

2. Добавление списка задач в таблицу

В каждой ячейке таблицы укажите задачу. В нашем примере одна из ячеек будет содержать «Общее количество предметов», вторая – «Упакованные предметы». Ячейка «Я готов» будет отображаться красным, если не все галочки в списке сняты, и зеленым, если флажки сняты все.

Откройте вкладку «Разработчик». Нажмите «Вставить» и в разделе «Элементы управления формы» выберите «Флажок» (иконку с галочкой).

3. Добавление флажков

Кликните на ячейку, в которую хотите добавить флажок. Вы увидите, что справа от поля флажка отображается текст. Так как нам нужно только поле, выделите текст и удалите его. После удаления текста размер поля не изменяется автоматически.

Если вы хотите изменить его, щелкните правой кнопкой мыши по ячейке, чтобы выбрать поле, а затем левой кнопкой мыши щелкните по нему. Таким образом вы сможете изменить его размеры и переместить на середину ячейки. Для того чтобы скопировать поле флажка и разместить его в других ячейках, выберите ячейку, а затем используйте кнопки управления курсором (клавиши со стрелками на клавиатуре) для перемещения к ячейке с флажком. Для того чтобы скопировать поле флажка в другие ячейки, наведите курсор в нижний угол ячейки, захватите его кнопкой мыши и протяните по ячейкам, в которые нужно скопировать поле. Отпустите кнопку мыши.

Расширенное форматирование списка

В зависимости от предназначения списка вы можете использовать расширенное форматирование.

Создание столбца ИСТИНА/ЛОЖЬ

Для этого нужно использовать колонку справа от полей с флажками. Флажок будет возвращать ИСТИНА (если галочка установлена) или ЛОЖЬ (если она снята). Таким образом вы сможете увидеть, все ли флажки сняты.

Правой кнопкой мыши нажмите на первое поле флажка и выберите «Формат объекта».

На вкладке «Элемент управления» в окне «Формат объекта» нажмите на кнопку выбора ячейки с правой стороны поля «Связь с ячейкой».

Выберите ячейку, которая находится справа от клетки с флажком. Адрес выбранной ячейки размещен в поле «Связь с ячейкой» в компактной версии окна «Формат объекта», чтобы развернуть его повторно нажмите на кнопку «Связь с ячейкой» и выберите «ОК». Повторите указанную процедуру для каждой ячейки в списке.

Общее число предметов и подсчет отмеченных предметов в списке

Укажите общее количество флажков в списке в ячейке, расположенной справа от клетки «Общее количество предметов». Число проставленных галочек можно подсчитать с помощью специальной функции. Введите

=СЧЁТЕСЛИ(C2:C8; ИСТИНА)

=COUNTIF(C2:C8,TRUE)

в ячейку справа от ячейки «Упакованные предметы» и нажмите Enter. Как показано в примере ниже, функция подсчитает число ячеек в колонке С (с С2 по С8), имеющих значение ИСТИНА или TRUE.

Скрыть столбец ИСТИНА/ЛОЖЬ

Для того чтобы скрыть данную колонку, правой кнопкой мыши кликните на ее заголовке и в отобразившемся меню выберите пункт «Скрыть». Столбец будет скрыт.

Как проверить, все ли галочки сняты

Для этого выберите ячейку «Я готов» и введите

=ЕСЛИ(B10=B11;”Да”;”Нет”)

=IF(B10=B11,”YES”,”NO”)

Если число в ячейке В10 совпадет со значением подсчитанных флажков в ячейке В11, в ней автоматически отобразится «Да», в противном случае появится «Нет».

Применение условного форматирования

С помощью условного форматирования вы можете выделить ячейки цветом. К примеру, вы можете задать условное форматирование таким образом, чтобы все ячейки со значениями определенного типа закрашивались в красный цвет.

Создайте правило, открыв «Главная» → «Условное форматирование» → «Создать правило» → «Диспетчер правил условного форматирования» → «Использовать формулу для определения форматируемых ячеек». Введите

=$B10<>$B11

в поле «Форматировать значения, для которых следующая формула является истинной:». Замените значения В10 и В11 адресами ячеек «Общее количество предметов» и «Упакованные предметы», если это не одни и те же ячейки.

Создайте еще одно правило, но в поле «Форматировать значения, для которых следующая формула является истинной:» введите формулу

=$B10=$B11

Затем нажмите «Формат», выберите цвет и нажмите «ОК».

В окне «Диспетчер правил условного форматирования» введите адреса ячеек, которые должны быть заполнены цветом, в поле «Применяется к». Введите те же адреса для обоих правил. В нашем случае это =$B$13. Нажмите «ОК».

Ячейка «Я готов» окрасится зеленым цветом, если все галочки будут сняты, или красным, если нет.

Добавить комментарий